2010/8/22:本掲示板は閲覧専用です。データが一部破損しておりますがご了承ください。
  新規投稿 ┃ツリー表示 ┃スレッド表示 ┃一覧表示 ┃トピック表示 ┃番号順表示 ┃検索 ┃設定 ┃過去ログ ┃ホーム  
10 / 332 ツリー ←次へ | 前へ→

CrystalDiskInfo 報告ツリー (2.7 以降) ひよひよ 09/5/5(火) 13:18

Re:I-O DATA HDCS-U1.0 ひよひよ 09/5/6(水) 22:08
Re:I-O DATA HDCS-U1.0 ひまわり 09/5/6(水) 22:17
Re:I-O DATA HDCS-U1.0 ひよひよ 09/5/6(水) 22:26
Re:I-O DATA HDCS-U1.0 sunp 09/5/6(水) 23:18 [添付][添付][添付]
Re:I-O DATA HDCS-U1.0 ひよひよ 09/5/7(木) 6:25
Re:I-O DATA HDCS-U1.0 ひよひよ 09/5/7(木) 21:35
Re:I-O DATA HDCS-U1.0 sunp 09/5/7(木) 22:01 [添付][添付][添付]
Re:I-O DATA HDCS-U1.0 ひよひよ 09/5/7(木) 22:25

Re:I-O DATA HDCS-U1.0
←back ↑menu ↑top forward→
 ひよひよ  - 09/5/6(水) 22:08 -

引用なし
パスワード
   ▼sunpさん:
>昨日報告したものです。
>実は私のI-O DATA HDCS-U1.0も今日試したら認識されないときがありました。
>
>で、色々試したのですが
>
>1)ハードウェアの安全な取り外しで、I-O DATA HDCS-U1.0を取り外す
>2)I-O DATA HDCS-U1.0の背面にあるボタン(電源連動機能のボタン?)をOFFする。
>3)背面にあるボタンをAUTOにする
>4)接続する
>5)CrystalDiscInfoで再検出
>
>で認識するようになりました。ここで、
>
>1)ハードウェアの安全な取り外しで、I-O DATA HDCS-U1.0を取り外す
>2)CrystalDiscInfoで再検出をし、I-O DATA HDCS-U1.0の表示を消す)
>3)I-O DATA HDCS-U1.0の背面にあるボタンを触らず、再度I-O DATA HDCS-U1.0を取り付ける
>4)CrystalDiscInfoで再検出
>
>とすると、I-O DATA HDCS-U1.0が検出されなくなりました。
>パソコンを再起動しても同様です(背面ボタンをOFF/ONするまで多分直りません)。
>
>背面のボタンをOFF/ONしたあと1回目に挿す場合と、2回目に挿す場合で挙動が変わっているのかもしれません。
詳細なレポートありがとうございます。
Dev#6 と 2.7.0 は実質同じものなのに挙動が異なるのは不思議に思っていましたがこのような状況なら納得です。
ひまわりさんの環境で動作しなかったのも同じような状況かもしれませんね。


>それがソフトウェア側でどうにかなる問題なのか、そうではないのかはよくわかりません。
大変お手数ですが、お時間があるときに一点実験していただけないでしょうか?

機能 > 上級者向け機能 > [DEBUG] USB/IEEE 1394 メニューで "Sunplus" のみをチェックした状態でご報告頂いた内容と同様のテストをしていただけないでしょうか。

先日頂いたテキストコピーを見る限り Sunplus 用コマンドで USB-HDD を認識しているのでそれ以外のコマンドを送らないようにした場合の挙動が知りたいのです。

各社のコマンドを順に送信していますが、今回の場合は Sunplus 用コマンドを送る前に I-O DATA 専用コマンドを送っています。上記のようにチェックを外すことにより I-O DATA 専用コマンドを送信しなくなります。

場合によっては実機購入の流れになりそうな悪寒がorz
見えたり見えなかったりは気持ち悪いですよね。はぁ。
売れ筋モデルだけになんとかしたいところです。

Re:I-O DATA HDCS-U1.0
←back ↑menu ↑top forward→
 ひまわり  - 09/5/6(水) 22:17 -

引用なし
パスワード
   >機能 > 上級者向け機能 > [DEBUG] USB/IEEE 1394 メニューで "Sunplus" のみをチェック
>した状態でご報告頂いた内容と同様のテストをしていただけないでしょうか。

実験してみました。すると今まで認識されていたアイ・オー・データのHDが認識されなくなりました

Re:I-O DATA HDCS-U1.0
←back ↑menu ↑top forward→
 ひよひよ  - 09/5/6(水) 22:26 -

引用なし
パスワード
   ▼ひまわりさん:
>>機能 > 上級者向け機能 > [DEBUG] USB/IEEE 1394 メニューで "Sunplus" のみをチェック
>>した状態でご報告頂いた内容と同様のテストをしていただけないでしょうか。
>
>実験してみました。すると今まで認識されていたアイ・オー・データのHDが認識されなくなりました
I-O DATA 用コマンドを送らなくなるので、I-O DATA 製は見えなくなります(^^;
これは、Sunplus 用コマンドで見える?HDCS-U1 が見えたり見えなかったりの問題の原因切り分けを目的としています。

実機なしでは苦しい雰囲気になってきましたねぇ。

Re:I-O DATA HDCS-U1.0
←back ↑menu ↑top forward→
 sunp  - 09/5/6(水) 23:18 -

引用なし
パスワード

[添付]〜添付ファイル〜
・名前 : Part01.png
・サイズ : 52.9KB

[添付]〜添付ファイル〜
・名前 : Part02.png
・サイズ : 52.8KB

[添付]〜添付ファイル〜
・名前 : Part03.png
・サイズ : 53.3KB
   >大変お手数ですが、お時間があるときに一点実験していただけないでしょうか?
>
>機能 > 上級者向け機能 > [DEBUG] USB/IEEE 1394 メニューで "Sunplus" のみをチェックした状態でご報告頂いた内容と同様のテストをしていただけないでしょうか。
>
>先日頂いたテキストコピーを見る限り Sunplus 用コマンドで USB-HDD を認識しているのでそれ以外のコマンドを送らないようにした場合の挙動が知りたいのです。
>
>各社のコマンドを順に送信していますが、今回の場合は Sunplus 用コマンドを送る前に I-O DATA 専用コマンドを送っています。上記のようにチェックを外すことにより I-O DATA 専用コマンドを送信しなくなります。
>
>場合によっては実機購入の流れになりそうな悪寒がorz
>見えたり見えなかったりは気持ち悪いですよね。はぁ。
>売れ筋モデルだけになんとかしたいところです。

実験A) 認識している状態で、[DEBUG] USB/IEEE 1394を弄ってみる
「SAT」か「JMicron」にチェックを入れたときは認識、それ以外は検出されなくなりました。SunplusやI-O DATA用のコマンドでは検出できません。

実験B) 「ハードウェアの安全な取り外し」で外し、ケーブルを抜き、背面ボタンはいじらず再度接続する
どのチェックを入れても検出されなくなる。背面ボタンをOFF/ONすると実験Aと同じ結果に

実験C)「ハードウェアの安全な取り外し」で外し、ケーブルを抜き、電源コードも抜き1分ほど放置(背面ボタンは触れず)
背面ボタンをOFF/ONした場合と同様の結果

--
また、背面ボタンをOFF/ONした場合や、電源を引っこ抜いた場合にしか「電源投入回数」が加算されないようです。
添付した画像は、Part01が実験Aのときのもの、Part02が実験BでHDDが検出された後のものです。間に「『ハードウェアの安全な取り外し』で外し、ケーブルを抜き、背面ボタンはいじらず再度接続する」という工程があるものの、1つしか加算されていません。
Part03の画像は実験Cで検出されたときのものです。「電源投入回数」が加算されているので、電源コードを抜くことは背面ボタンをOFF/ONするのと同等の効果が得られるようです。

あと、背面ボタンを押した後や、電源コードを挿した場合に一度HDDが回転してから停止します。

・・・どうやら、背面ボタンをONにしておくとHDDは完全停止状態ではなくディスクの回転だけ止めているスタンバイ状態のようです。

添付画像
【Part01.png : 52.9KB】

添付画像
【Part02.png : 52.8KB】

添付画像
【Part03.png : 53.3KB】

Re:I-O DATA HDCS-U1.0
←back ↑menu ↑top forward→
 ひよひよ  - 09/5/7(木) 6:25 -

引用なし
パスワード
   ▼sunpさん:
>実験A) 認識している状態で、[DEBUG] USB/IEEE 1394を弄ってみる
>「SAT」か「JMicron」にチェックを入れたときは認識、それ以外は検出されなくなりました。SunplusやI-O DATA用のコマンドでは検出できません。
完全に勘違いしておりました。
sa1 なので、Sunplus ではなく、SAT でした。自分で定義した形式なのに勘違い・・・
すいません。
JMicron でも見えるということなので、SAT 対応ファームウェア搭載(?)の JMicron チップということのようですね。

>実験B) 「ハードウェアの安全な取り外し」で外し、ケーブルを抜き、背面ボタンはいじらず再度接続する
>どのチェックを入れても検出されなくなる。背面ボタンをOFF/ONすると実験Aと同じ結果に
>
>実験C)「ハードウェアの安全な取り外し」で外し、ケーブルを抜き、電源コードも抜き1分ほど放置(背面ボタンは触れず)
>背面ボタンをOFF/ONした場合と同様の結果
ようするに、一度抜くと電源をOFF/ONしない限り見えないと・・・。

>また、背面ボタンをOFF/ONした場合や、電源を引っこ抜いた場合にしか「電源投入回数」が加算されないようです。
>添付した画像は、Part01が実験Aのときのもの、Part02が実験BでHDDが検出された後のものです。間に「『ハードウェアの安全な取り外し』で外し、ケーブルを抜き、背面ボタンはいじらず再度接続する」という工程があるものの、1つしか加算されていません。
>Part03の画像は実験Cで検出されたときのものです。「電源投入回数」が加算されているので、電源コードを抜くことは背面ボタンをOFF/ONするのと同等の効果が得られるようです。

>あと、背面ボタンを押した後や、電源コードを挿した場合に一度HDDが回転してから停止します。
>
>・・・どうやら、背面ボタンをONにしておくとHDDは完全停止状態ではなくディスクの回転だけ止めているスタンバイ状態のようです。
なるほど。

だとするとソフトウェア側の改良で対処するのは難しそうですねぇ。理由はわかりませんが、一度取り外すと SAT/JMicron 用特殊コマンドが通らなくなると・・・。ひょっとすると再接続後には初期化コマンドのようなものを一度送る必要があるのかもしれませんが仕様書もないので・・・。

とはいえ、他の JMicron 搭載 USB-HDD では今回のようなレポートを頂いたことはないので I-O DATA 側で何らかのカスタマイズが入っているのかもしれません。

実機購入も含めて対応方針について検討してみます。
GW最終日(?)にも関わらず詳細なテストをしていただきありがとうございました。

Re:I-O DATA HDCS-U1.0
←back ↑menu ↑top forward→
 ひよひよ  - 09/5/7(木) 21:35 -

引用なし
パスワード
   ▼sunpさん:
JMicron 製 USB 変換チップに対応したソフトの HDD Scan (http://hddscan.com/)
でどのような挙動になるかご確認いただけないでしょうか。

同じような挙動なら・・・。

Re:I-O DATA HDCS-U1.0
←back ↑menu ↑top forward→
 sunp  - 09/5/7(木) 22:01 -

引用なし
パスワード

[添付]〜添付ファイル〜
・名前 : Part01(2).png
・サイズ : 56.6KB

[添付]〜添付ファイル〜
・名前 : Part02(2).png
・サイズ : 56.1KB

[添付]〜添付ファイル〜
・名前 : Part03(2).png
・サイズ : 56.0KB
   ▼ひよひよさん:
>▼sunpさん:
>JMicron 製 USB 変換チップに対応したソフトの HDD Scan (http://hddscan.com/)
>でどのような挙動になるかご確認いただけないでしょうか。
>
>同じような挙動なら・・・。

残念ながら(?)、同じ挙動ではありませんでした(検出できました)。

Part01 - CrystalDiskInfo 2.7.0で検出可能な状態でのキャプチャ
Part02 - 「ハードウェアの安全な取り外し」をした後、再び接続
Part03 - HDDの背面ボタンをOFF/ONした後

Part02のとき、CrystalDiskInfo2.7.0は検出できませんでした。

Part01, Part02間ではStart/StopCountは1増え、Device Power Cycle Countは増えず
Part02, Part03間では両方1ずつ増。

添付画像
【Part01(2).png : 56.6KB】

添付画像
【Part02(2).png : 56.1KB】

添付画像
【Part03(2).png : 56.0KB】

Re:I-O DATA HDCS-U1.0
←back ↑menu ↑top forward→
 ひよひよ  - 09/5/7(木) 22:25 -

引用なし
パスワード
   ▼sunpさん:
>残念ながら(?)、同じ挙動ではありませんでした(検出できました)。
ご確認ありがとうございました。

ソースコードを見ても原因は分かりませんので、購入して確認したいと思います。
1万円は安くありませんが、延々と検証につき合わせるのも申し訳ないので。
今週末には購入し改良したいと思いますので、修正版が出来たらテストにご協力ください。

10 / 332 ツリー ←次へ | 前へ→
  新規投稿 ┃ツリー表示 ┃スレッド表示 ┃一覧表示 ┃トピック表示 ┃番号順表示 ┃検索 ┃設定 ┃過去ログ ┃ホーム  
ページ:  ┃  記事番号:   
95419
(SS)C-BOARD v3.8(とほほ改ver2.1) is Free