2010/8/22:本掲示板は閲覧専用です。データが一部破損しておりますがご了承ください。
  新規投稿 ┃ツリー表示 ┃スレッド表示 ┃一覧表示 ┃トピック表示 ┃番号順表示 ┃検索 ┃設定 ┃ホーム  
6 / 376 ツリー ←次へ | 前へ→

【995】CrystalCPUID 感想&要望&バグ報告 ひよひよ 04/5/31(月) 0:26

【1727】Re:A8N-Delux + Athlon64 X2 4400+ + Win2k ひよひよ@X2欲しい 05/8/8(月) 23:43
【1728】Re:A8N-Delux + Athlon64 X2 4400+ + Win2k あんず 05/8/10(水) 15:25
【1731】Re:A8N-Delux + Athlon64 X2 4400+ + Win2k あんず 05/8/12(金) 22:31
【1732】Re:A8N-Delux + Athlon64 X2 4400+ + Win2k ひよひよ@X2欲しい 05/8/13(土) 0:28
【1736】Re:A8N-Delux + Athlon64 X2 4400+ + Win2k あんず 05/8/17(水) 11:15
【1737】Re:A8N-Delux + Athlon64 X2 4400+ + Win2k ひよひよ@X2欲しい 05/8/17(水) 12:19

【1727】Re:A8N-Delux + Athlon64 X2 4400+ + Win2k
←back ↑menu ↑top forward→
 ひよひよ@X2欲しい  - 05/8/8(月) 23:43 -

引用なし
パスワード
   ▼あんずさん:
>バグ?かと思われる現象を報告いたします。
>2005/7/29のバージョンで(それ以前のバージョンでも起きましたが…)
>長時間起動していると、いつのまにかCrystalCPUIDがCPUを独占してしまい
>しかも独占中は常にCPUをフルロードしているようで、
>うちの場合Athlon64 X2の片方が使用率100%(タスクマネージャで50%)で独占されてしまいます。
>タスクマネージャのプロセスの終了でも終わらせることができなくなり、
>再起動を行おうとしても、Windowsも終了できなくなり、強制リセット、
>もしくは電源の強制OFFをするしかなくなってしまいます。
>
>確実な再現性がない為、うちの環境が悪いのか、
>なにか相性の悪いソフトが入っているのかは、わかりませんが、
>一応報告しておきます。
ご報告ありがとうございます。
長時間使っていると・・・っていうのはソフトウェアとして致命的かつ見つかりにくい不具合を抱えている証拠だと思われます。
一点確認したいのは、長時間起動というのはMultiplier Managementを有効にした状態でしょうか?もし、MMが有効であるならマルチスレッド周りの問題かと思われます。あと、ひょっとすると倍率&電圧を切り替えているまさにその瞬間に別な割り込みが入ってうまくいかなくなってるとかそういう可能性もあります。実際、while(1)で動作モード切替完了を待つ部分もありますし。。。

そこらへんを中心にもうちょっと詳しくレポートしていただけると助かります。
お手数をおかけしますがよろしくお願いいたします。

【1728】Re:A8N-Delux + Athlon64 X2 4400+ + Win2k
←back ↑menu ↑top forward→
 あんず  - 05/8/10(水) 15:25 -

引用なし
パスワード
   ▼ひよひよ@X2欲しいさん:

>一点確認したいのは、長時間起動というのはMultiplier Managementを有効にした状態でしょうか?
>もし、MMが有効であるならマルチスレッド周りの問題かと思われます。
>あと、ひょっとすると倍率&電圧を切り替えているまさにその瞬間に
>別な割り込みが入ってうまくいかなくなってるとかそういう可能性もあります。
>実際、while(1)で動作モード切替完了を待つ部分もありますし。。。

御察しの通りMultiplier ManagementをOnにしている状態で起こっております。
(逆に言えばMMを実行しないのであればCrystalCPUIDを長時間起動はしないということになりますが…)
あれ以来現象が起きていないので、また現象が出ましたらば報告いたします。
おきるときは起動後30分程度で起こるのですが…

これは気分的な問題なのかもしれませんが、RealtimeClockのみを表示させたままにしておくと
いくらか現象が出にくくなっているような気がします。
最小化、タスクトレイアイコンのみの状況下で一番問題が出ていました。

【1731】Re:A8N-Delux + Athlon64 X2 4400+ + Win2k
←back ↑menu ↑top forward→
 あんず  - 05/8/12(金) 22:31 -

引用なし
パスワード
   例の占有問題が再発したのでご報告いたします。

今回はPSPをUSBに挿しまして、デバイスの認識(PnP新規デバイスの自動認識)をしたところ
CrystalCPUIDの反応がなくなり、例のCPU占有問題が発生いたしました。

また、その他でも起こるようなら報告いたします。

【1732】Re:A8N-Delux + Athlon64 X2 4400+ + Win2k
←back ↑menu ↑top forward→
 ひよひよ@X2欲しい  - 05/8/13(土) 0:28 -

引用なし
パスワード
   ▼あんずさん:
>例の占有問題が再発したのでご報告いたします。
>
>今回はPSPをUSBに挿しまして、デバイスの認識(PnP新規デバイスの自動認識)をしたところ
>CrystalCPUIDの反応がなくなり、例のCPU占有問題が発生いたしました。
>
>また、その他でも起こるようなら報告いたします。
根本的な問題だなぁ〜とは思います。

【1736】Re:A8N-Delux + Athlon64 X2 4400+ + Win2k
←back ↑menu ↑top forward→
 あんず  - 05/8/17(水) 11:15 -

引用なし
パスワード
   例の占有問題が再発したのでご報告いたします。

今回は
Smartvision(MPEG2タイムシフト再生/オーバーレイ)2.1.2.0
IE6.0.2800.1106
Firefox1.06/ja
OpenJane 0.1.12.2
を起動使用中に
Windows Media Player 9.00.00.3250
を起動しWMVを再生中(VMR使用・起動後?メディアファイルの切り替え時?)にCPUIDがスタックしたようです。
感じとしては、ビデオ再生時やオーバーレイ使用時に比較的おこりやすいのかなぁ?
などと感じております。
ただ単に、ビデオ関係を起動している時間が長いのでそう感じているだけかもしれませんが…(^-^;

CPUがフルロードされると、ただでさえ暑い室温があがってしまうので
CrystalCPUID.exプロセスが終了できるようになるだけでもありがたいのですが…(ぉ

【1737】Re:A8N-Delux + Athlon64 X2 4400+ + Win2k
←back ↑menu ↑top forward→
 ひよひよ@X2欲しい  - 05/8/17(水) 12:19 -

引用なし
パスワード
   ▼あんずさん:
>例の占有問題が再発したのでご報告いたします。
う〜む、かなりの頻度で発生していますね・・・。
私の Mobile Athlon XP-M 環境をずっとつけっぱなしにして CrystalCPUID のテストをしているのですが、今のところ再現していません。マルチプロセッサでのみ発生する不具合なのかな???と開発者でさえこの調子なのでこの問題は根が深いです。申し訳ない。

で、解決策として現在考えているのは、CrystalCPUID 5.x では、Multiplier Management 部を別実行ファイルにしてしまうこと。そうすることで、本体も MM もシングルスレッドプログラムとして実装することが可能となり処理がシンプルになります。このような問題が発生する根本的な原因はソースコードがよれよれになり、特定の条件、特定のタイミングでのみ発生する不具合が発生しやすい状況に陥っていることだと思うのでそこらへんを今後直していきたいと思っております。

すぐに 5.x を出せる状況にないのが苦しいところですが・・・。

6 / 376 ツリー ←次へ | 前へ→
  新規投稿 ┃ツリー表示 ┃スレッド表示 ┃一覧表示 ┃トピック表示 ┃番号順表示 ┃検索 ┃設定 ┃ホーム  
ページ:  ┃  記事番号:   
52079
(SS)C-BOARD v3.8(とほほ改ver2.1) is Free